jump to navigation

[Firefox] Estrazione di tabelle…da HTML a SQL in un istante 16 dicembre 2008

Posted by LukePet in Chicche, Estensioni, Firefox, Informatica, Internet, Prodotti, Programmi, Software, Soluzioni, Sviluppo, Utility, Web.
Tags: , , , ,
add a comment

E’ bello quando ti viene commissionato un lavoretto da fare e dopo qualche ricerca sul web becchi un’estensione di Firefox che già lo fa per te.

Dunque il problema era questo: “C’è una pagina HTML statica da cui bisogna estrarre le informazioni contenute in una table (decisamente voluminosa!) e salvarle in excel o preferibilmente riportarle in un database. ”

Come fare? Semplice…basta installare OutWit Hub!

Questa estensione consente di analizzare il contenuto delle sorgenti web ed estrarre i dati di interesse…è possibile isolare le tabelle contenute in una pagina e selezionare i dati di cui si necessita per poi estrarli in diversi formati. E’ possibile esportare i dati o come fogli elettronici o come script SQL per popolare le tabelle del proprio database.

Semplice ed utile.

Per approfondire la cosa basta cliccare qui:
http://www.outwit.com/products/hub/.

Buone estrazioni.

Annunci

[Chicche] Crash di explorer.exe…il giorno grigio di BitDefender! 10 dicembre 2008

Posted by LukePet in Chicche, Informatica, Internet, Prodotti, Sistema, Software, Soluzioni, Web, Windows.
Tags: , , , , ,
6 comments

Qualche tempo fa Punto Informatico ha pubblicato un articolo dal titolo “Il Giorno Nero di AVG” in cui si parlava del grave problema che l’antivirus aveva dato a molti utenti a causa di un maledetto aggiornamento…ho preso in prestito quel titolo, riadattandolo un pò, per segnalarvi ciò che mi è successo tra ieri ed oggi con il mio antivirus BitDefender. Ora vi spiego.

BitDefender Internet Security 2009 ed il mio Vista 64bit non sembrano proprio andare d’accordo. Un mese fa vi parlai del problema che avevo avuto (poi risolto) con l’accesso ad alcuni siti (chicche-inspiegabile-pagina-bianca-dopo-il-login-forse-e-questa-la-possibile-soluzione), oggi invece vi parlo di ciò che mi è successo tutto d’un tratto ieri nel bel mezzo di una serena serata.

Per dirla in breve. Vista ha iniziato a dare di matto! Se selezionavo icone, file o cartelle non riuscivo in alcun modo ad aprire il menu contestuale…il processo explorer.exe andava immediatamente in crash e si riavviava. Ma non solo, non riuscivo neanche ad eliminare, copiare o tagliare i file…anche utilizzando i comandi rapidi ctrl+c, ctrl+x, canc, etc. Insomma il sistema era diventato quasi inutilizzabile.

Poi ho fatto qualche ricerca, scritto su un paio di forum ed infine, grazie ad un suggerimento ricevuto, ho provato a disinstallare BitDefender per vedere se poteva essere lui la causa di tutto il disagio…manco a dirlo, era colpa sua.

Ora sento di dover dedicare due righe al mio amato antivirus…

Non ci siamo caro Bit, mi stai deludendo in questa nuova versione 2009…comunque, ora dopo averti reinstallato sembra tutto ok. Staremo a vedere cosa ci riserva il futuro…fatto sta che il nostro rapporto è in crisi…e pensare che ti ho voluto tanto bene fino ad oggi. Ora ti dò una seconda possibilità, se sgarri è finita!

Vabbè, basta così…lasciatemi solo con il mio dolore per un rapporto incrinato.

Se qualcuno di voi si trovasse nella mia stessa situazione ora sa quale potrebbe essere la possibile causa.

[Chicche] WordPress, Apache e i permalink 07 dicembre 2008

Posted by LukePet in Chicche, Guide, Informatica, Software, Soluzioni, Sviluppo.
Tags: , ,
add a comment

Comunicazione di servizio…

Se vi capitasse di installare WordPress in locale e dopo aver abilitato i permalink le pagine del blog risultassero inaccessibili, allora molto probabilmente il vostro server locale ha una configurazione non adatta.

Se state usando Apache allora dovrete editare il file httpd.conf ed abilitare le seguenti impostazioni:

1) Cercate il modulo mod_rewrite e abilitatelo:
LoadModule rewrite_module modules/mod_rewrite.so (in pratica dovete trovare questa istruzione e togliere il carattere # che la precede)

2) Andate nella sezione “Directory” ed impostate AllowOverride All :
<Directory "C:/Programmi/Apache Software Foundation/Apache2.2/htdocs">
# Possible values for the Options directive are
# "None", "All", or any combination of:
Options Indexes FollowSymLinks
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
AllowOverride All
# Controls who can get stuff from this server.
Order allow,deny
Allow from all
<Directory>

A questo punto salvate, riavviate il server Apache ed avrete i permalink funzionanti.

E’ tutto.

[Chicche] Installare Windows XP su una partizione in cui è gia installato Windows Vista…è stata dura ma alla fine ce l’ho fatta! 01 dicembre 2008

Posted by LukePet in Chicche, Guide, Informatica, Periferiche, Prodotti, Programmi, Sistema, Software, Soluzioni, Windows.
Tags: , , , , ,
15 comments

Qualche settimana fa ho avuto l’esigenza di installare Windows XP sul mio nuovo PC, nella stessa partizione in cui era già installato Windows Vista…la cosa, apparentemente banale, si è rivelata più ardua del previsto. Girovagando tra i forum ho visto che non sono l’unico ad aver avuto qualche problemino con questo tipo di operazione; ora vi riporto per bene tutto ciò che ho fatto per raggiungere l’obiettivo.

Dunque, avevo due partizioni a disposizione è volevo installare XP recuperando spazio dalla partizione su cui è installato Vista, lasciando l’altra partizione completamente a disposizione dei vari dati…e fin qui siamo. Vista integra già di suo un gestore delle partizioni così ho pensato “Niente di più facile!”…sono andato in “Pannello di controllo -> Strumenti di amministrazione -> Gestione computer -> Archiviazione -> Gestione disco”, da qui ho selezionato la partizione che mi interessava è ho cliccato sulla voce “Riduci volume…”. E qui è arrivata la sorpresina…di ben 300Gb liberi ne potevo recuperare solo 40!!

Mi sono messo così alla ricerca delle possibili cause…ho deframmentato il disco, disabilitato il ripristino della configurazione di sistema, disabilitato l’ibernazione e disabilitato il file di paging (vi basta andare su “Pannello di Controllo -> Sistema -> Impostazioni di sistema avanzate” per smanettare un pò con le varie impostazioni). Dopo essermi cimentato con tutte queste operazioni ho provato a ridurre nuovamente il volume della partizione…niente, ho solo recuperato pochi altri giga, niente di più.

Alle fine leggendo qua e là ho capito che bisognava deframmentare il disco con qualche programma ad hoc… (altro…)

[Chicche] Video del Google Developer Day 14 novembre 2008

Posted by LukePet in Chicche, Documenti, Informatica, Internet, Linguaggi, Multimedia, Prodotti, Programmazione, Segnalazioni, Siti, Sviluppo, Tutorial, Video, Web, YouTube.
Tags: , , , , ,
add a comment

Ieri Google Italia ha inserito su YouTube, diversi video dei seminari svolti al Google Developer Day lo scorso 21 Ottobre a Milano. Io c’ero stato ed avevo scritto il mio bel resoconto in questo post: chiacchiere-due-parole-sul-developer-day-di-google.

Se qualcuno fosse interessato a seguire alcuni dei seminari seduto comodamente davanti al proprio monitor può dare un’occhiata qui: http://www.youtube.com/user/GoogleItalia; l’unico inconveniente è che questa volta non c’è modo di usufruire della traduzione simultanea.

Io mi limito a riportarvi il contributo video del seminario sulla geolocalizzazione che ho trovato piuttosto interessante, ben fatto; credo sia stato l’unico puramente in italiano. Eccolo:

Per il resto vi basta visitare il canale YouTube di Google Italia.

Buona visione.